Mantis Benutzeranleitung

Michael Olschimke

Martin Fuchs

2007

Zusammenfassung

Inhaltsverzeichnis

1. Vorwort
2. Glossar
3. Anmeldung
4. Übersicht und grundsätzlicher Aufbau
5. Probleme anzeigen
6. Einrichten eines Filters
7. Probleme anzeigen
8. Bedeutung des Status
9. Probleme bearbeiten
10. Erweiterte Anzeige
11. Probleme eingeben
12. Felder im Detail
13. Das Schreiben von guten Änderungsanforderungen (Best Practices)
14. Dokumentation
15. Konto
16. Einstellungen ändern
17. Profil-Verwaltung
This document was created using the >e-novative> DocBook Environment (eDE)


1. Vorwort

Mantis ist ein Web-basiertes Change Request Management System, welches von der MantisBT group (http://www.mantisbt.org) entwickelt und unter der GPL veröffentlicht wurde. Change Request Management ist ein wichtiger Prozess in der Softwareentwicklung, unabhängig davon, ob ein agiler Prozess wie Extreme Programming oder ein klassischer Ansatz verfolgt wird. Im Prinzip geht es um sogenanntes Bug Tracking, also das Sammeln von Fehlern (oder allgemeiner: Einträge) einer Software. Zusätzlich werden während der Bearbeitung der Eintrag weitere Informationen gesammelt, beispielsweise Diskussionen über die Anforderung, wem die Anforderung zugewiesen wurde, etc.


2. Glossar

2.1. Eintrag
2.2. Bug Tracker
2.3. Bugzilla
2.4. Change Request Management System
2.5. GPL
2.6. Mantis


2.1. Eintrag

Eine Eintrag bezeichnet im Änderungswesen von Projekten einen formalisierten Wunsch nach Veränderung der Eigenschaften einer bestimmten Produktversion. Jede Eintrag wird in einem kontrollierten Prozess bewertet, entschieden und kommuniziert.


2.2. Bug Tracker

Bug-Tracker (engl. bugreport, bugtracker) sind in der Software-Entwicklung eingesetzte Computerprogramme, die als Werkzeug der Erfassung und Dokumentation von Programmfehlern dienen. Mit ihnen werden, oft interaktiv und im Internet, auch Status- oder Feature-Berichte geschrieben.

Daneben nehmen sie auch Verbesserungsvorschläge und Wünsche der Nutzer oder allgemeine Vorgänge auf. Bei manchen Projekten spricht man dann zum Beispiel von Metabugs. Diese beschreiben hierbei ein Element einer Aufgabenliste, ohne dass sich dies direkt auf einen Softwarefehler oder einen Änderungswunsch bezieht. Bei anderen Projekten spricht man stattdessen von „Issues“ (Angelegenheiten), da sich dieser Ausdruck nicht auf Programmfehler beschränkt.


2.3. Bugzilla

Bugzilla ist ein Computerprogramm zur Verwaltung und Verfolgung von Hinweisen auf Fehler (englisch: bug reports) in Software und Wünschen nach zusätzlichen Funktionen (englisch: feature requests).


2.4. Change Request Management System

Siehe Bug Tracker.


2.5. GPL

Die GNU General Public License (GPL) ist eine von der Free Software Foundation herausgegebene Lizenz für die Lizenzierung freier Software.


2.6. Mantis

Mantis ist ein Computerprogramm zur Verwaltung und Verfolgung von Hinweisen auf Fehler (englisch: bug reports bzw. Bug Tracker) in Software und Wünschen nach zusätzlichen Funktionen (englisch: feature requests).


3. Anmeldung

TODO


4. Übersicht und grundsätzlicher Aufbau

Nach erfolgter Anmeldung erscheint die sogenannte Übersicht. Dies ist eine personalisierte Sicht auf alle gesammelten Einträge. Aber beginnen wir mit dem grundsätzlichen Aufbau von Mantis:

die personalisierte Übersicht von Mantis

Abbildung 1. die personalisierte Übersicht von Mantis

(1) Mit Hilfe dieser Auswahlbox ist es möglich, das aktuelle Projekt zu wechseln. Auch ist es möglich sich eine Übersicht über alle Projekte zu denen man eine Berechtigung hat zu erhalten. Dabei werden einfach die Einträge aus allen Projekten zusammengeführt.

(2) Der Bereich darunter bietet Zugriff auf alle Funktionen von Mantis:

  1. Startseite

    Diese Seite zeigt News vom Serverbetreiber oder vom Projektmanager an. Die Nachrichten sind auch als RSS Feed verfügbar (auf der Seite).

  2. Übersicht

    Wie bereits erwähnt, eine personalisierte Sicht auf die Einträge. Dies ist die Standardseite des Systems.

  3. Probleme anzeigen

    Diese Seite zeigt alle Einträge an, die im System gespeichert sind.

  4. Probleme eingeben

    Dient zum eingeben neuer Einträge.

  5. Änderungsprotokoll

    TODO

  6. Dokumentation

    Möglichkeit zum Ablegen projektbezogener Dokumente und zum Zugriff auf die Mantis-Dokumentation.

  7. Konto

    Hier können persönliche Angaben und Einstellungen vorgenommen werden.

  8. Abmelden

    Log-out aus Mantis


5. Probleme anzeigen

Abbildung 2. Einträge anzeigen

Diese Seite gibt alle Einträge anhand eines definierten Filters aus. Der Filter kann im oberen Bereich der Seite (1) festgelegt werden. Im unteren Bereich (2) werden dann die Einträge angezeigt.


6. Einrichten eines Filters

Ein Filter kann mit Hilfe der Links im oberen Bereich (1) der Seite eingerichtet werden. Nachdem ein Attribut ausgewählt wurde, wird eine Auswahlbox für das dazugehörige Feld eingeblendet. Darin kann dann der Wert, auf den gefiltert werden soll, eingegeben oder ausgewählt werden.

Abbildung 3. Auswirkung

Auf diese Weise können zum Beispiel nur die Einträge mit einer bestimmten Auswirkung angezeigt werden.

Abbildung 4. Filter

Nach Auswahl des Schalters Filter wird dieser Filter angewandt. Mit Auswahl des Schalters Filter Speichern ist es möglich, diesen Filter dauerhaft zu speichern. In diesem Fall erfolgt die Abfrage eines Namen für den neuen Filter.

Danach steht der Filter auf der Seite Probleme anzeigen zur Verfügung:

Anzeige mit Filterung

Abbildung 5. Anzeige mit Filterung


7. Probleme anzeigen

Nachdem nun der Filter eingerichtet ist, ist nun der Bereich darunter von Interesse. Dieser führt die eigentliche Funktion der Seite aus, nämlich die Einträge anzuzeigen.

Jede Eintrag bekommt eine systemweit eindeutige ID. Das bedeutet, dass diese ID auch nicht in anderen Projekten vergeben wird. Zusätzlich wird eine Zusammenfassung gezeigt und wann der Datensatz zuletzt aktualisiert wurde. Weiterhin wird der Status angezeigt. Dieser Status spiegelt sich auch in der Farbe der Zeile wieder. Dabei kommen folgende Farbgebungen zum Einsatz:


8. Bedeutung des Status

Im Änderungsmanagement kommt dem Status neben der Lösung eine besondere Bedeutung zu. Er ist einer der wichtigsten Kriterien für Filter.

Wenn eine Eintrag aufgenommen wird, so erhält sie den Status neu. Dies sollte keiner weiteren Erklärung bedürfen. Im Normalfall sollte nun der Projektverantwortliche eingreifen und festlegen, ob eine Eintrag angenommen (durchgeführt) werden soll oder nicht. Dazu dient der Status anerkannt. Bei Wechsel des Status kann derjenige, der diesen Wechsel durchführt der Eintrag eine Notiz beifügen. Auch dies ist ein wichtiges Feature von Mantis.

Nachdem die Eintrag anerkannt wurde, sollte nun ein Teammitglied prüfen, ob beispielsweise das beschriebene Fehlverhalten zutrifft, dass heißt, ob es sich wirklich um einen Fehler handelt. In diesem Fall wechselt der Status von anerkannt nach bestätigt. Nun ist der Projektverantwortliche wieder am Zug, die Eintrag muss einem Teammitglied zugewiesen werden. Dieses erledigt dann die Eintrag. Danach muss beispielsweise durch den Projektverantwortlichen oder durch ein Mitglied der Qualitätssicherung geprüft werden, ob die Anforderung korrekt umgesetzt wurde. In diesem Fall wechselt der Status auf geschlossen.

Eine wichtige Empfehlung ist, niemals Einträge zu löschen. Zwar ist dies möglich, jedoch gehen so viele, wertvolle Informationen verloren. Sinnvoller ist die Einrichtung eines Filters mit dem die geschlossenen Filter nicht angezeigt werden. Aus dem gleichen Grund sollten auch so viele Notizen wie möglich den Einträge angehängt werden, beispielsweise Protokolldateien bei der Fehlersuche, detailierte Fehlerbeschreibungen, Workarounds, Ursachen für Fehler, etc. Auch oder besonders wenn etwas nicht umgesetzt wird, sollte dies auf diese Weise dokumentiert werden.


9. Probleme bearbeiten

Wird die ID der Eintrag ausgewählt, so wird die Anforderung detailiert mit Hilfe der Einfachen oder Erweiterten Problemanzeige dargestellt:


10. Erweiterte Anzeige

Ob die einfache oder die erweiterte Problemanzeige verwendet wird hängt von den gewählten Einstellungen auf der Seite Konto ab (Näheres dazu unter Konto-Einstellungen).

Interessant sind die Links im oberen Bereich der Eintrag. Mit diesen kann nicht nur schnell zwischen den einzelnen Bereichen hin- und hergesprungen werden, es können auch spezielle Aktionen durchgeführt werden. Beispielsweise kann zur einfachen Anzeige gewechselt oder eine Erinnerung gezielt an eine bestimmte Person gesendet werden:

Versenden einer Erinnerung an ausgewählte Empfänger

Abbildung 6. Versenden einer Erinnerung an ausgewählte Empfänger

Die versendete Nachricht wird sowohl als Notiz an die Eintrag gehängt als auch per Email an die ausgewählten Personen verschickt.

Zurück zur Problemanzeige. Im unteren Bereich ist es möglich, verschiedene Eigenschaften des Eintrags zu editieren bzw. die oben beschriebenen Statuswechsel herbeizuführen:

Abbildung 7. Eintrag

  1. Mit Hilfe der Funktion Aktualisieren ist es möglich, alle angezeigten Daten zu ändern.

  2. Die Funktion Zuordnen zu weist die Zuständigkeit für die Eintrag an ein auswählbares Teammitglied.

  3. Um den Status der Eintrag zu ändern, kann die Funktion Status wechseln zu verwendet werden.

  4. Ein wichtiges und nützliches Feature ist die Beobachtung eines Problems mit Hilfe des Schalters Problem beobachten.

    Sobald eine Änderung an dem Eintrag durchgeführt wird, erhält man automatische eine Email-Nachricht.

  5. Um eine ähnliche Eintrag zu erzeugen, kann man die Funktion Klon erzeugen nutzen.

    Dadurch werden alle gesetzten Eigenschaften in einen neuen Eintrag kopiert.


11. Probleme eingeben

Neben dem Ändern von Änderungsanforderungen ist es natürlich auch möglich, neue Einträge einzugeben. Dabei unterscheidet Mantis zwischen einem einfachen und einem erweiterten Bericht.

Abbildung 8. erweiterter Bericht

Während der einfache Bericht die Felder

  • Kategorie

  • Reproduzierbar

  • Auswirkung

  • Priorität

  • Zusammenfassung

  • Beschreibung

  • Zusätzliche Informationen

  • Datei übertragen

  • Anzeigestatus

  • Im Eingabemodus bleiben

enthält, beinhaltet der erweiterte Bericht zusätzlich die folgenden Felder:

  • Profil bzw.

    • Rechnertyp

    • Betriebssystem

    • BS-Version

  • Produktbuild

  • Zuordnung an

  • Schritte zur Reproduktion.

Zwischen den Berichten lässt sich mit Hilfe des Links oben rechts umschalten.


12. Felder im Detail

12.1. Kategorie
12.2. Reproduzierbar
12.3. Auswirkung
12.4. Priorität
12.5. Profil wählen
12.6. Rechnertyp
12.7. Betriebssystem
12.8. BS Version
12.9. Produktbuild
12.10. Zuordnung an
12.11. Zusammenfassung
12.12. Beschreibung
12.13. Schritte zur Reproduktion
12.14. Zusätzliche Informationen
12.15. Datei übertragen
12.16. Anzeigestatus
12.17. Im Eingabemodus bleiben

In den nächsten Abschnitten werden die Felder im Detail besprochen.


12.1. Kategorie

Gibt normalerweise die Kategorie an, in der der Fehler auftritt, kann z. B. Dokumentation, Installationsroutine oder etwas ähnliches sein (Vom Benutzer definierbarer Wert).


12.2. Reproduzierbar

Gibt an, ob und wie der Fehler reproduzierbar ist. Die folgenden Werte sind möglich:

  • Immer

  • Manchmal

  • Zufällig

  • Nicht getestet

  • Nicht reproduzierbar

  • N/A


12.3. Auswirkung

Die Auswirkung gibt die Schwere des Fehlers an und kann einen der folgenden Werte annehmen:

  • Feature-Wunsch

  • Trivial

  • Fehler im Text

  • Unschönheit

  • Kleinerer Fehler

  • Schwerer Fehler

  • Absturz

  • Blocker


12.4. Priorität

Die Priorität gibt an, wie wichtig eine Bearbeitung der Änderungsanforderung ist, folgende Werte sind möglich:

  • Keine

  • Niedrig

  • Normal

  • Hoch

  • Dringend

  • Sofort


12.5. Profil wählen

Mit Hilfe des Profils kann das eigene System angegeben werden. Sollten keine Profile vorhanden sein, so ist es möglich, das System in den Einstellungen (siehe Profil-Verwaltung aufzunehmen oder mit Hilfe der Felder Rechnertyp, Betriebssystem und BS Version manuell für diesen Fehler anzugeben.


12.6. Rechnertyp

Dieses Feld sollte dazu genutzt werden um die Hardware-Plattform anzugeben, auf dem der Fehler aufgetreten ist.


12.7. Betriebssystem

Gibt allgemein das Betriebssystem an, beispielsweise MS Windows oder Linux.


12.8. BS Version

Die Version des Betriebssystems, auf dem der Fehler aufgetreten ist. Beispielsweise 2000, XP Professional oder Redhat 9.


12.9. Produktbuild

Hier sollte die Programm-Version, in der der Fehler aufgetreten ist, angegeben werden.


12.10. Zuordnung an

In diesem Feld kann ein Team-Mitglied ausgewählt werden, welches die Meldung bearbeiten soll.


12.11. Zusammenfassung

Die Zusammenfassung sollte den Team-Mitgliedern einen kurzen Überblick über die zu erwartende Änderungsanforderung geben.


12.12. Beschreibung

In der Beschreibung sollte nun stehen, um was es in der Änderungsanforderung geht, also welche Änderungen durchgeführt werden sollen.


12.13. Schritte zur Reproduktion

Wenn es sich bei der Änderungsanforderung um einen Fehler handelt, sollte neben der Beschreibung des Fehlers auch angegeben werden, wie der Fehler reproduziert werden kann. Dies ist wichtig für das Auffinden des Fehlers.


12.14. Zusätzliche Informationen

Dieses Feld bietet sich beispielsweise für Fehlermeldungen, Logs, etc. an.


12.15. Datei übertragen

Einer Änderungsanforderung kann auch eine Datei beigefügt werden. Die maximale Größe hängt von der Systemeinstellung ab. Wenn nötig können jedoch weitere Anhänge später über die Bearbeitung der Änderungsanforderung hinzugefügt werden.


12.16. Anzeigestatus

Mit Hilfe des Anzeigestatus kann angegeben werden, ob die Änderungsanforderung öffentlich einsehbar ist oder nur von Team-Mitgliedern.


12.17. Im Eingabemodus bleiben

Wenn die Auswahl markiert ist, dann wird nach Versendung der Änderungsanforderung eine neue Eingabemaske geöffnet, bei der die Felder Kategorie, Reproduzierbar, Auswirkung, Priorität und Profil mit den gleichen Werten wie in dieser Änderungsanforderung vorbelegt sind.


13. Das Schreiben von guten Änderungsanforderungen (Best Practices)

13.1. Sun Developer Network: How to Write a Helpful Bug Report
13.2. Mozilla.Org: Bug Writing Guidelines

Je besser Änderungsanforderungen formuliert sind, je mehr Informationen über die Wünsche oder den Fehler beinhalten, desto einfacher ist es, den Fehler zu beseitigen. Auf der anderen Seite hilft Prosa oder ausschmücken der Fehlerbeschreibung nicht weiter. Im Internet lassen sich gute Best Practices zum diesem Thema finden, einige werden in den nächsten Abschnitten vorgestellt, es wird empfohlen diese vor Verwendung von Mantis zu lesen.


13.1. Sun Developer Network: How to Write a Helpful Bug Report

http://java.sun.com/developer/technicalArticles/bugreport_howto


13.2. Mozilla.Org: Bug Writing Guidelines

https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html


14. Dokumentation

Neben dem Erfassen von Änderungsanforderungen ist es in Mantis auch möglich, Dokumentationen zu sammeln. TODO


15. Konto

Mit Hilfe der nun folgenden Seiten kann Mantis individuell auf die eigenen Bedürfnisse angepasst werden.

Die erste Seite enthält dabei die eigentlichen Konteninformationen zu dem derzeitig eingeloggten Benutzer. Hier kann das Passwort, die Email-Adresse, an die Benachrichtigungen geschickt werden sollen und der richtige Name angegeben werden.

Bearbeiten der Kontoeinstellungen

Abbildung 9. Bearbeiten der Kontoeinstellungen


16. Einstellungen ändern

Auf dieser Seite ist es möglich, das Verhalten von Mantis anzupassen, beispielsweise, wann Mantis Emails an den aktuell eingeloggten Benutzer schicken soll, ob überhaupt Emails versendet werden sollen oder ob standardmäßig ein einfacher oder erweiterter Bericht verwendet werden soll.

Abbildung 10. Mantis-Konfiguration


17. Profil-Verwaltung

In der Profil-Verwaltung ist es möglich, Rechner- und Betriebssystem-Konfigurationen zu hinterlegen. Diese werden bei der Aufnahme neuer Änderungsanforderungen (siehe Probleme eingeben bzw. Profil wählen) verwendet (in der erweiterten Darstellung).

die Profil-Verwaltung in Mantis

Abbildung 11. die Profil-Verwaltung in Mantis